OLEXP: Your Outlook Express Password Is Not Retained in
Windows 2000 or XP
The information in this article applies to:
- Microsoft Outlook Express 5.5 for Windows 2000
- Microsoft Outlook Express 5.01 for Windows 2000
- Microsoft Outlook Express 6.0 for Windows XP
This article was previously published under Q264672
For information about the differences between Microsoft Outlook Express and
Microsoft Outlook e-mail clients, click the following article number to view
the article in the Microsoft Knowledge Base:
257824 OL2000: Differences Between Outlook and Outlook Express
IMPORTANT: This article contains information about
modifying the registry. Before you modify the registry, make sure to back it
up and make sure that you understand how to restore the registry if a problem
occurs. For information about how to back up, restore, and edit the registry,
click the following article number to view the article in the Microsoft
Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you run Outlook Express using Microsoft Windows 2000 or Microsoft
Windows XP and connect to your Internet Service Provider (ISP) to retrieve
e-mail messages from a Post Office Protocol (POP) server, your password is not
retained even though you have chosen to save it.
CAUSE
The registry contains incorrect information for the Protected
Storage System Provider registry subkey for your account.
RESOLUTION
To save your password you must back up your registry, remove the user
account information, and then re-enter your password. Only people who are
members of the Administrators group on the local computer can make these
changes. Windows XP Home Edition users need to check the Users control panel.
If they are not listed as an Administrator, someone with Administrator rights
will have to add them to the Administrators group.
WARNING: If you use Registry Editor incorrectly, you may
cause serious problems that may require you to reinstall your operating
system. Microsoft cannot guarantee that you can solve problems that result
from using Registry Editor incorrectly. Use Registry Editor at your own risk.
How to Back up the Registry
Windows 2000
- Click Start, click Run, type
regedt32 in the Open box, and then click
OK.
- Locate and click the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Protected
Storage System Provider
- On the Registry menu, click Save Key.
- In the File name box, type a unique name
for the key.
- In the Save In box, click a location for the file, and
then click Save.
- On the Registry menu, click Exit.
Windows XP
- Click Start, click Run, type
regedt32 in the Open box, and then click OK.
- Locate and click the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Protected
Storage System Provider
- On the File menu, click Export.
- In the File name box, type a unique name
for the key.
- In the Save In box, click a location for the file, and
then click Save.
- On the Registry menu, click Exit.
How to Remove the User Account Information
Windows 2000
- Quit all programs.
- Click Start, click Run, type
regedt32 in the Open box, and then click
OK.
- Locate and click the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Protected Storage
System Provider
- On the Security menu, click Permissions.
- Click the registry key for the user that is currently logged on and
ensure that Read and Full Control are both
set to Allow.
- Click the Advanced button, ensure that user that is
currently logged on is selected, that Full Control is
listed in the Permissions column, and that
This Key and Subkeys is listed in the
Apply to column.
- Click to select the Reset permissions on all
child objects and enable propagation of inheritable permissions
check box.
- Click Apply, and then click Yes when
you are prompted to continue.
- Click OK, and then click OK.
- Double-click the Protected Storage System
Provider key to expand the key, click the user subkey folder that
is directly below the Protected Storage System
Provider key, click Delete on the Edit
menu, and then click Yes in the warning message dialog box.
The user subkey folder looks similar to the following example:
S-1-5-21-124525095-708259637-1543119021-16701
NOTE: For every identity that you have, there will be a
subkey under the Protected Storage System Provider
key. To resolve this problem in all of your identities, you must delete all
of the user subkeys folders under the Protected
Storage System Provider key.
- On the Registry menu, click Exit, and
then restart your computer.
Windows XP
- Quit all programs.
- Click Start, click Run, type
regedit32 in the Open box, and then click OK.
- Locate and click the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Protected
Storage System Provider
- On the Edit menu, click Permissions.
- Click the registry key for the user that is currently logged on and
ensure that Read and
Full Control permissions are both set to
Allow.
- Click the Advanced button, ensure that the user that is
currently logged on is selected, that Full Control
is listed in the Permissions column, and that
This Key and Subkeys is listed in the
Apply to column.
- Click to select the Replace permission entries on
all child objects with entries shown here that apply to child objects
check box.
- Click Apply, and then click Yes when
you receive a prompt to continue.
- Click OK, and then click OK again.
- Double-click the Protected Storage System
Provider key to expand the key, click the user subkey folder that
is directly below the Protected Storage System Provider key, click
Delete on the Edit menu, and then click
Yes in the warning message dialog box.
The user subkey folder looks similar to the following example:
S-1-5-21-124525095-708259637-1543119021-16701
NOTE: For every identity that you have, there may be a
subkey under the Protected Storage System Provider key. To resolve this
issue in all of your identities, you must delete all of the user subkeys
folders under the Protected Storage System Provider key.
- On the Registry menu, click Exit, and
then restart your computer.
How to Re-Enter Your Password
NOTE: These steps work for both Windows 2000 and Windows
XP.
- Start Outlook Express.
NOTE: If you receive a login error, close the dialog box
and proceed.
- Click Tools, and then click Accounts.
- Click the Mail tab in the Internet Accounts
window.
- In the Account column, click to highlight the Internet
E-mail account to be changed, and then click Properties.
- On the Server tab, type your password in the
Password box, and then click to select
Remember password dialog box.
- Click OK, and then click Close.
- Close Outlook Express and then restart it.
- On the Tools menu, click Send
and Receive to test if your password is retained.
NOTE: If other Windows 2000 or Windows XP users are having
password retention problems, re-enter the password, and then click to select
the Remember Password check box for those profiles. Each user may need to log
on for their password to be retained.
| Last
Reviewed: |
10/30/2002 |
| Keywords: |
kbprb KB264672 |