"Fatal Error" Error Message Occurs When You Run WINIPCFG
The information in this article applies to:
- Microsoft Windows Millennium Edition
- Microsoft Windows 98 Second Edition
- Microsoft Windows 98
This article was previously published under Q286748
IMPORTANT: This article contains information about modifying
the registry. Before you modify the registry, make sure to back it up and make
sure that you understand how to restore the registry if a problem occurs. For
information about how to back up, restore, and edit the registry, click the
following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you click Start, click Run and then
run the Winipcfg command, you may receive the following error
message:
Fatal Error, Cannot read IP configuration
When you attempt to run ipconfig from a command line, you
may receive the following error message:
IP Configuration Fatal Error, Cannot read IP configuration
CAUSE
This issue can occur if one of the following conditions exists:
- Transmission Control Protocol/Internet Protocol (TCP/IP) is installed,
but it is not bound to any adapters.
-or-
- The TCP/IP stack is corrupted.
WORKAROUND
WARNING: If you use Registry Editor incorrectly, you may
cause serious problems that may require you to reinstall your operating
system. Microsoft cannot guarantee that you can solve problems that result
from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To resolve this issue, confirm the TCP/IP settings and the binding:
- Click Start, click Settings, and then
click Control Panel.
- Double-click Network, and then verify that TCP/IP is
installed.
If TCP/IP is not installed, click Add, click
Protocol, and then click Add again. Click
Microsoft in the Manufacturer box, click
TCP/IP, and then click Add.
- If TCP/IP is installed, click your first network adapter, and then click
Properties.
NOTE: Perform this step for each network adapter.
- Click the Bindings tab, and then verify that the
TCP/IP check box has been selected.
If the TCP/IP check box has not been selected, click to
select the TCP/IP check box, and then click OK.
If you have confirmed that TCP/IP is installed and bound to all adapters,
and you still receive the error message described in the "Summary" section of
ths article, reinstall the TCP/IP stack.
NOTE: Before you begin this procedure, record your network
configuration information.
To remove and reinstall the TCP/IP stack:
- Click Start, Settings, click
Control Panel, and then double-click Network.
- For each installed instance of TCP/IP, record all the settings, and then
remove all TCP/IP-related network components from Network properties.
- Click Cancel.
- Click Start, click Settings, click
Control Panel, and then double-click Add/Remove
Programs.
- Click the Windows Setup tab, and then double-click
Communications.
- Click to clear the Dial-Up Networking check box, and
then click OK.
When you receive the following message, click OK twice, and
then restart the computer:
Dial-up Networking is required by the following
component(s) "List of components". Removing it will also remove these
components. Do you want to remove Dial-up Networking and all components that
require it?
- Click Start, click Run, and then type
regedit.
- Export and delete the WinSock2 registry keys that are
located in the following registry settings, and then restart the computer:
- HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\AFVXD
- HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\DHCP
- HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\MSTCP
- HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\Winsock
- HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VXD\Winsock2
- HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock
- HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WinSock2
- HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RemoteAccess\Authentication\SMM_Files
- In Control Panel, double-click Add/Remove programs,
click the Windows Setup tab, double click
Communications, and then click to select the Dial-Up
Networking check box.
- Click OK, click Apply, click
OK, and then restart the computer.
- In Control Panel, double-click Network, and then verify
that the network configuration is complete.
NOTE: If you are missing a network item, reinstall that
item now.
If you still receive the error message that is described in the "Summary"
section of this article, manually replace some of the TCP/IP files that may
have been corrupted:
- Start the computer with the Windows Startup floppy disk in drive A.
If you do not have a Startup disk, click Start, click
Settings, click Control Panel, and then
double-click Add/Remove programs. Click Startup
Disk, and then click Create Disk . Follow the
instructions to create a Startup disk.
- After you restart the computer from a Startup disk, click
Start computer with CD-ROM support.
- In Microsoft Windows 95, Microsoft Windows 98, and Microsoft Windows 98
Second Edition, at the command prompt, type the following commands (one
command for each line), and then press ENTER after each command:
- c:
- cd \windows\system
- ren vip.386 vip.old
- ren vtcp.386 vtcp.old
- ren vtdi.386 vtdi.old
- ren vudp.386 vudp.old
- ren vdhcp.386 vdhcp.old
- ren vnbt.386 vnbt.old
NOTE: These files now need to be reextracted from the
Windows installation CD-ROM. If you are using Windows Millennium Edition
(Me), you can extract these files from the cabinet (.cab) files that are
located in the C:\Windows\Options\Install folder.
In Windows Me, after you type all of the earlier commands, type the
following command and then press ENTER:
ren tcpip.sys tcpip.old
NOTE: You must extract the TCP/IP files while in DOS or
Windows will prevent the operation from completing successfully.
When you complete this step (step 3), you rename the existing TCP/IP files
that may have been corrupted.
- Restart the computer into Windows to reextract these files.
If you are using Windows 98 or Windows 98 Second Edition, use the SFC
utility to re-extract the files.
For additional information about how to use the SFC utility, click the
article number below to view the article in the Microsoft Knowledge Base:
129605 How to Extract Original Compressed Windows Files
If you are using Windows Me, use the Msconfig utility (Msconfig.exe) to
extract new copies of the files. For additional information about how to use
Msconfig.exe, click the article number below to view the article in the
Microsoft Knowledge Base:
265371 How to Extract and Replace a Protected File in Windows Me
- Restart Windows after all these files are replaced, and then run the
Winipcfg command.
REFERENCES
For additional information, click the article numbers below to view the
articles in the Microsoft Knowledge Base:
141698 How to Use Winipcfg to View TCP/IP Settings
191064 Error Messages When Running TCP/IP-Based Utilities or Programs
| Last
Reviewed: |
6/12/2002 |
| Keywords: |
kbenv kberrmsg kbprb KB286748 |