Error Message Appears When You Try to Start Internet Explorer

The information in this article applies to:
This article was previously published under Q308780
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you start Internet Explorer (IE), you may receive the following error message:
 

Page cannot be displayed

If you try to gain access to a Web site by entering the IP address of the site in the address bar, you may receive the following error message:
 

Unable to locate server

CAUSE

This behavior can occur if the following registry key is corrupted:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinSock2

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this behavior, import a clean copy of the WinSock2 key into the registry:

  1. On a Windows 2000-based computer that is able to open IE with no error, save a clean copy of the WinSock2 key:
    1. Start Registry Editor (Regedt32.exe).
    2. Locate the following key in the registry:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinSock2

    3. Insert a floppy disk into the floppy disk drive.
    4. Select the key, and then on the Registry menu, click Save. Save the clean copy of the key onto the floppy disk.
    5. Quit Registry Editor.
  2. On the Windows 2000-based computer that is experiencing the error, import the clean copy of the key into the registry:
    1. Start Registry Editor (Regedt32.exe).
    2. Locate the following registry key:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinSock2

    3. To delete the existing WinSock2 key, click the key, and then on the Edit menu, click Delete.
    4. Insert the floppy disk into the floppy disk drive.
    5. On the Registry menu, click Restore. Specify that you want to restore the clean key that you saved on the floppy disk.
    6. Quit Registry Editor.
  3. Restart your computer.

MORE INFORMATION

This behavior can occur if a third-party Winsock program is installed on the system.

Last Reviewed: 9/24/2002
Keywords: kbenv kberrmsg kbprb kburl KB308780